mysql-query-browser : compiling from open source sucks

trying to compile mysql-query-browser, when i give …
configure: error: Package requirements (libglade-2.0
gthread-2.0
libxml-2.0 >= 2.6.2
libgtkhtml-3.0
gtkmm-2.4) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable

I tried all and somewhere suggested steps as below:
1. First build mysql-gui-common
2. then, > cd mysql-query-browser
./configure –with-gtkhtml=libgtkhtml-3.8 && make && make install

Still, it sucks, when this should not have been so messy complicated for a semi-techie leave the normal end user developer.
I came across articles for knowledge enhancement on this , just thought to compile at one place for my own reference and sharing.

Best :: http://ronaldbradford.com/blog/2006/01/18/

Other ::
http://bugs.mysql.com/bug.php?id=27519
http://bugs.mysql.com/bug.php?id=31042

Advertisements

2 Responses to “mysql-query-browser : compiling from open source sucks”

  1. Why would an end user want to compile mysql query browser…

  2. saffrongeek Says:

    I had ubuntu version 8 and it didnt had any programming or related in release on my machine. so i started setting up my machine for development tools and kit. So I thought to do a compile rather use the package manager and this post i guess was the first one in this regard. I have later posted a neater way to install mysql GUI in my blog.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: